Older versions of Torpedo Remote and BlendIR

To perform some firmware updates, or to keep on using your Torpedo hardware with outdated macOS and Windows versions, you need to install legacy versions of Torpedo Remote. Here are all the links you need inregards to each OS.

Remote 4.0.3:

Mac OSX: https://public-downloads.two-notes.com/setups/remote/Torpedo_Remote_4.0.3_Mac_Update.dmg

Windows: https://public-downloads.two-notes.com/setups/remote/Torpedo_Remote_4.0.3_PC_Update.exe

Remote 3.1.15:

Mac OSX: https://public-downloads.two-notes.com/setups/remote/Torpedo_Remote_3.1.15_Mac_Update.dmg

Windows: https://public-downloads.two-notes.com/setups/remote/Torpedo_Remote_3.1.15_PC_Update.exe

Remote VB101:

Mac OSX: https://public-downloads.two-notes.com/setups/remote/Torpedo_Remote_VB101_3.2.0_Mac_Update.dmg

Windows: https://public-downloads.two-notes.com/setups/remote/Torpedo_Remote_VB101_3.2.0_PC_Update.exe

 

If you wish to use the BETA version of BlendIR on your computer, here are the download links for Windows and macOS (not compatible with Catalina and above). BlendIR is not supported anymore in our current infrastructure.

 

Blend IR 0.9.8:

Mac OSX: https://public-downloads.two-notes.com/setups/blendir/Torpedo_BlendIR_0.9.8_Mac_Setup.dmg

Window: https://public-downloads.two-notes.com/setups/blendir/Torpedo_BlendIR_0.9.8_PC_Setup.exe